IRC log for #koha, 2013-11-22

All times shown according to UTC.

Time S Nick Message
00:10 wizzyrea is it cold?
00:11 eythian @wunder nzwn
00:11 huginn eythian: The current temperature in Wellington, New Zealand is 17.0°C (1:00 PM NZDT on November 22, 2013). Conditions: Overcast. Humidity: 77%. Dew Point: 13.0°C. Pressure: 30.12 in 1020 hPa (Steady).
00:11 eythian no.
00:14 ibeardslee that's almost tropical
00:32 * eythian tries to figure out why 3.14 won't build...
00:33 rangi failing silently?
00:33 eythian nah, dependency problem
00:33 rangi ahh
00:34 bag @wunder 93102
00:34 huginn bag: The current temperature in Westside, Santa Barbara, California is 15.9°C (4:34 PM PST on November 21, 2013). Conditions: Scattered Clouds. Humidity: 81%. Dew Point: 12.0°C. Pressure: 29.80 in 1009 hPa (Rising).
00:34 bag close but welly pulls out the win today
00:34 eythian there's a couple of packages that aren't in squeeze that it wants.
00:35 dcook @wunder sydney, australia
00:35 huginn dcook: The current temperature in Sydney, New South Wales is 23.0°C (11:00 AM EST on November 22, 2013). Conditions: Mostly Cloudy. Humidity: 69%. Dew Point: 17.0°C. Pressure: 29.80 in 1009 hPa (Steady).
00:36 dcook :D
00:45 eythian OK, updating deps on wheezy causes a failed build on squeeze, good to know.
00:47 wizzyrea hahahaha
00:47 wizzyrea http://koha-community.org/file[…]d-kohabanner3.jpg
00:48 wizzyrea ^ magic
00:49 BobB_ joined #koha
00:51 bag heya BobB
00:54 BobB joined #koha
00:55 BobB hi bag
00:56 bag YAY it's BobB :)
00:56 bag one of my favs :)
00:56 BobB :)
00:56 BobB I just used a Bywater blog entry to explain 'relevance' to a client - excellent post, thank you
00:56 bag awesome :)
00:57 bag YAY
00:57 bag and with that - it's time to take this needy doggie home… Mr Aloo has had his full for the day
00:57 BobB catch ya later
00:58 bag only a few more months of him being in the office and he'll submit his first patch
00:58 bag more treats will be the patch
01:03 Irma joined #koha
01:21 wizzyrea bug 8584
01:21 huginn Bug http://bugs.koha-community.org[…]w_bug.cgi?id=8584 enhancement, P5 - low, ---, fcapovilla, Pushed to Master , Improve cleanup_database.pl to only purge emails older than X days.
01:42 wizzyrea @later tell bgkriegel hiyas - fyi, since the posts are no longer on the home page of koha-community.org, we don't need to put the "more" tags in (i don't even know if you were doing this - I'm just telling all of the maintainers) Cheers!
01:42 huginn wizzyrea: The operation succeeded.
01:43 wizzyrea @later tell tcohen hiyas - fyi, since the posts are no longer on the home page of koha-community.org, we don't need to put the "more" tags in (i don't even know if you were doing this - I'm just telling all of the maintainers) Cheers!
01:43 huginn wizzyrea: The operation succeeded.
01:59 busla joined #koha
02:13 tcohen joined #koha
02:16 jenkins_koha Starting build #132 for job Koha_3.12.x (previous build: FAILURE -- last SUCCESS #130 6 hr 42 min ago)
02:16 mtompset Greetings, busla tcohen
02:17 mtompset Out of curiosity, we have an offline circulation tool.
02:17 mtompset Do we have an offline data entry tool?
02:18 tcohen marcedit?
02:18 wahanui i heard marcedit was a tool for editing MARC records. It can also convert spreadsheets to MARC. See http://people.oregonstate.edu/[…]it/html/index.php
02:18 busla hey mtompset
02:18 wahanui it has been said that mtompset is catching up in the non-coding aspects of his ministry.
02:18 mtompset The problem with marcedit is it requires knowledge of MARC.
02:19 mtompset What about something for people who know nothing of library things?
02:19 mtompset And to be honest, I asked why not marcedit too, tcohen. :)
02:20 tcohen hi mtompset
02:20 tcohen too busy these days
02:20 tcohen this
02:21 mtompset Well, being an RM is kind of time consuming. :)
02:22 jcamins mtompset: vim.
02:23 jcamins But, no, cataloging isn't exactly a mission-critical function in the type of library that needs an ILS like Koha.
02:24 dpk1 joined #koha
02:25 jcamins And the cataloging module would have to be completely redone to be usable in offline mode.
02:27 mtompset Unless this tool just gave plain data entry type labels for things and generated a .mrc file to import.
02:27 wizzyrea ^^ is what I was about to say
02:28 jcamins mtompset: right, but we already have that.
02:28 jcamins "vim" was a non-ironic response.
02:28 wizzyrea I like the new place holds interface in the OPAC
02:28 mtompset vim?!
02:28 wizzyrea good work that.
02:28 mtompset How?
02:28 jcamins Write records in marc breaker format, then use marc maker to compile them.
02:30 mtompset marc breaker format requires knowledge of things like 260$a, 260$b, 260$c, etc. etc.
02:30 mtompset That ties into the MARCEdit answer.
02:30 jcamins If MARCedit will run on your computer, it's pretty much the same.
02:32 eythian 3.14 and 3.15 packages uploading.
02:33 eythian s/ing/ed/
02:35 gdunbar joined #koha
02:35 wizzyrea \o/ thanks robin!
02:35 wizzyrea i mean eythian >.<
02:35 tcohen o/ yay robin!
02:37 tcohen wizzyrea: which tags should and shouldn't use?
02:38 wizzyrea for your releases, you'll want to use categories, so releases, and 3.12 (or are you 10? Whichever applies.)
02:39 wizzyrea it used to be that we'd use the <!-- more --> tag to split the posts
02:39 wizzyrea so that they didn't overwhelm the home page.
02:39 tcohen so the only change would be the more tag
02:39 wizzyrea yarp
02:39 wizzyrea it's just not necessary
02:39 wizzyrea anymroe
02:39 eythian @karma <!
02:39 huginn eythian: Karma for "<!" has been increased 14 times and decreased 130 times for a total karma of -116.
02:39 wizzyrea more*
02:41 jenkins_koha Project Koha_3.12.x build #132: STILL FAILING in 25 min: http://jenkins.koha-community.[…]/Koha_3.12.x/132/
02:42 tcohen @later tell rangi it is possible that there's a problem with the jenkins script, i cannot seem to find the tests results
02:42 huginn tcohen: The operation succeeded.
02:43 rangi naw its a problem that the junit.xml file is on the slave, and the master cant get it
02:43 rangi ill have to figure some way round it
02:44 tcohen thanks rangi
02:45 tcohen i was worried for the maintenance release failing the tests
02:54 jcamins Gosh, Spanish hot chocolate is wonderful.
03:00 mtompset 3.15 packages?
03:00 wizzyrea always marching forward we are.
03:01 mtompset You package master occasionally?
03:02 eythian yeah
03:02 eythian ideally regularly, but realistically occasionally
03:02 eythian it's good to know that something hasn't slipped in that stops it building.
03:02 phasefx2 joined #koha
03:03 mtompset eythian: But doesn't Jenkin's failures catch that?
03:03 gdunbar joined #koha
03:04 eythian In theory, in practice I get the motivation to fix it when it's not working for _me_.
03:05 mtompset Ah, good point.
03:05 mtompset okay... question.
03:05 wahanui question is "What is the meaning of life, the universe and everything?"
03:05 mtompset 42.
03:05 mtompset But seriously, wahanui...
03:05 wahanui mtompset: sorry...
03:05 mtompset git checkout -b blah v3.14.00
03:06 mtompset git rebase
03:06 mtompset gives me a nice error.
03:06 mtompset There is no tracking information for the current branch.
03:06 mtompset How would you set tracking information?
03:07 eythian you haven't told it about an upstream to rebase against
03:07 wizzyrea git checkout -b blah --track origin/v3.14.00
03:07 eythian well, that's an answer
03:07 eythian but what are you trying to do?
03:07 eythian because it doesn't look like you're doing the right thing.
03:08 eythian there's also no point tracking a tag
03:08 mtompset well, thinking about it, git rebase doesn't make sense, since 3.14.00 is fixed in time.
03:08 eythian it never changes.
03:08 eythian yes
03:09 mtompset I suppose I can consider the error a "Why are you trying to do something dumb?" message. :)
03:09 eythian yeah :)
03:10 mtompset Though, actually. This does cause me to wonder...
03:10 mtompset Why is there no moving 3.14.x tag?
03:10 rangi tags never move
03:10 jcamins mtompset: because tags don't move.
03:10 mtompset ah... is there a 3.14.x branch?
03:11 eythian yes
03:12 mtompset And that's what I really wanted then!
03:13 eythian quite probably :)
03:13 eythian I think branching from another branch will track it by default, but I'm not 100% sure.
03:13 eythian tracking a tag isn't really meaningful.
03:13 mtompset I think you are right, but I'm not sure either.
03:13 eythian either way, --track will do it
03:15 mtj afaik, a tag is just a friendly alias for a commit
03:15 eythian yep
03:15 eythian so is a branch, it just can move
03:16 * eythian => 'beer o'clock',
03:17 mtompset print $time{eythian};
03:32 mtompset Is there a way to git bz unapply?
03:33 jcamins mtompset: git reset --hard or git checkout ${whatever_you_want_to_checkout}
03:48 mtompset jcamins: git rebase -i allows you to delete a commit from the list. I think that might be it.
03:49 jcamins You can do that too if you prefer.
03:50 mtompset Handy if you did it a couple commits back. :)
04:06 mtompset okay. Finally got 3.14+tweaks distribution rolling. :)
04:22 rambutan joined #koha
04:59 * dcook waves
04:59 dcook Hmm, maybe my browser is just not working..
05:06 phasefx2 joined #koha
05:12 edveal joined #koha
05:23 rambutan joined #koha
05:26 * mtompset is waiting for the rsync.
05:33 busla joined #koha
06:13 rambutan joined #koha
06:17 dpk1 joined #koha
06:25 cait joined #koha
06:26 mtompset And there's my QA system back.
06:39 laurence joined #koha
06:43 mtompset_ joined #koha
06:44 phasefx2 joined #koha
06:44 dcook Have a good Friday/weekend all
06:44 mtompset I think that blip is a sign.
06:44 mtompset Have a great day, #koha.
06:45 gdunbar joined #koha
06:59 rambutan joined #koha
07:25 pug joined #koha
07:29 phasefx2 joined #koha
07:30 gdunbar joined #koha
07:40 reiveune joined #koha
07:40 reiveune hello
07:40 wahanui niihau, reiveune
07:44 sophie_m joined #koha
07:44 * cait waves
07:44 cait later all
07:44 cait left #koha
07:45 paul_p joined #koha
07:51 ashimema joined #koha
07:55 alex_a joined #koha
08:13 gaetan_B joined #koha
08:14 gaetan_B hello
08:36 cait joined #koha
08:36 cait hi #koha
08:40 paul_p joined #koha
09:08 cait bonjour paul_p
09:26 busla joined #koha
09:30 pug Hi guys
09:30 pug anyone has a demo installation to take a look at 3.14 OPAC?
09:56 Joubu pug: see http://wiki.koha-community.org[…]ha_Demo_Databases
10:04 pug Joubu - hey thanks - so the head is indeed at 3.14, right?
10:05 rambutan joined #koha
10:11 Joubu pug: head is master. master has just 4 small fixes above 3.14
10:11 pug cool - thanks!
10:12 pug Joubu - I have another small question Ive not found a decent ans to - its quite a relevant issue from this region of the world-
10:14 pug Im looking for a CLI tool to convert csv data to marc records that can be used with bulk_import.pl
10:14 pug since Around here not many marc records exist to begin with
10:27 pug Hi Joubu - around?
10:38 Joubu pug: yep, sorry. No I don't know how to convert csv to marc records.
10:50 cait joined #koha
11:01 sophie_m joined #koha
11:14 sophie_m left #koha
11:15 sophie_m joined #koha
11:19 pug So  in many parts of the world- the catalog data is already in some marc format or the other, is it?
11:19 cait some people use marcedit
11:19 cait or build htier own scripts for migration
11:19 cait there are some in the repo
11:21 cait hm at least i thought there were
11:22 cait so probably there is none available currently
11:29 sophie_m joined #koha
11:32 sophie_m alex_a: est-ce qu'une de tes interventions pour MT 12257 aurait pu produire MT 13013 ?
11:32 sophie_m !ping
11:32 sophie_m oups
11:32 sophie_m sorry wrong chan :-[
11:33 sophie_m hello #koha :-)
11:40 cait hi sophie_m :)
11:42 slef hi everyone - what's new?
11:42 cait pi.
11:42 cait :)
11:43 pug cait - yeah - I tried to look - I couldnt find any in the repo.. marc edit is what we use currently - but its difficult to use with the GUI, esp if you have many items per bib record to map
11:43 cait pug: migrating data is always a big project - hope you can work it out
11:44 pug if I were to build a script - which is the easist format to convert the csv to? .. marcxml or marc21?
11:44 slef marcxml is an encoding of marc21
11:45 slef there are already at least two sets of csv to marcxml conversion tools around - catalyst's is probably the easiest to find
11:45 pug is it!
11:45 pug slef - you mean command line tools?
11:46 slef pug: yeah I think both sets are. Most GUI types use marc edit somehow (I don't know that well... one of the command line toolsets is mine)
11:47 slef bbl
11:49 pug oh cool - slef ++
11:49 pug can you share a link for bbl?
11:51 pug ok  - I take that back -- can you share a link for your* tool?
12:04 pug slef - let me know once you are back - really looking for a solution!
12:12 slef back
12:13 slef pug: I thought we'd published it but I'm not finding it on http://www.software.coop/source/ - if we haven't then it'll take me a while to update it
12:15 slef pug: I thought the other tools would be on http://git.catalyst.net.nz/gw but that's being slow to answer me
12:17 slef pug: aha, https://gitorious.org/koha-toolbox is bywater's toolset
12:20 pug cool! -- let me check this stuff
12:30 pug Thanks a ton! -- this actually has many useful scripts - yeah, including csv to marc -- Ill test these. Hopefully contrib back if there are any holes! -- slef ++
12:32 jwagner joined #koha
12:45 cait slef++ # fixing whitespace :)
12:48 tcohen joined #koha
12:49 meliss joined #koha
12:52 busla joined #koha
13:18 cait khall: around?
13:18 khall yo
13:18 cait hi :)
13:18 khall mornin!
13:18 cait I have run into some serious probldms with the restrictions last night - and we were not sure how it is supposed to wrk
13:18 cait maybe you could take a look?
13:18 khall absolutley!
13:19 cait bug 11282
13:19 huginn Bug http://bugs.koha-community.org[…]_bug.cgi?id=11282 blocker, P5 - low, ---, koha-bugs, NEW , Not possible to create multiple restrictions from patron details/new restriction overwrites existing
13:20 cait we got a bit confusedon irc last night about it, but i think my test plan shoudl give you an idea (hopefully)
13:21 khall I'm on it
13:23 cait thank you :)
13:24 tcohen morning
13:24 cait hi tcohen :)
13:24 tcohen hi cait
13:25 khall wow, it always removes the restriction with the date furthest in the future
13:25 oleonard joined #koha
13:25 tcohen gmcharlt?
13:25 wahanui i heard gmcharlt was an expert in all things library technology.
13:25 cait i noticed some difference in where you edit it - i couldn't even add a second one from the patron edit screen, but only from the restrictions tab on the checkouts page
13:26 francharb joined #koha
13:28 francharb good morning all
13:29 cait hi francharb :)
13:29 francharb hi cait
13:29 khall cait, you can add multiple restrictions but you have to save and go back for each one
13:30 cait hmmm
13:30 cait that didn't work for me
13:30 cait when you add one
13:30 cait it kicks you out of the screen and back to details after saving
13:30 cait i then edited again and it didn't add another, but kiilled my first one
13:30 khall right, because of the bug
13:31 cait ok, that makes sense
13:31 cait :)
13:31 khall I have a fix, it'll be up momentarility
13:31 cait at first we were confused because the option to have more than one is new
13:31 cait cool :)
13:34 khall cait, it's a one line patch. I think it's safe to take directly to QA if you want to
13:34 khall it's up now
13:34 khall would you like me to deal with the untranslatable strings now?
13:34 cait it#s a bit of a sensitive spot - maybe better to have 2 testers
13:34 cait if you got time :)
13:34 cait I like to log the bugs before I forget
13:35 cait i have filed one for that
13:35 cait did you see it? bug 11283
13:35 huginn Bug http://bugs.koha-community.org[…]_bug.cgi?id=11283 normal, P5 - low, ---, koha-bugs, NEW , Restriction type is not translatable
13:36 khall I just saw your note in the last bug, workin on it!
13:36 cait khall: about the restrictions: will the debarred/debarredcomment fields in borrowers still be used? which restriction goes there?
13:36 cait khall: shoudl be easy to do in the templates, we have done it in a few places now for hardcoded strings from the database
13:37 cait with TT this is soooo much easier
13:37 khall cait, what happens is the date for the "longest" restriction is but into borrowers.debarred, and the comments for all the restrictions are concatenated and put in debarredcomment. That we it's faster and didn't have to change as much code
13:38 cait khall: what will happen when i load new patrons with debarred set?
13:38 NateC joined #koha
13:40 khall that is a most excellent question, the answer is you've uncovered a bug. It'll work fine until another restriction is added, and you won't be able to delete the imported restriction. However, if you create a new restriction and delete that one, it would overwrite and then delete the imported restriction
13:41 cait *confused*
13:41 cait we got a library doing that... so I am a bit worried now:)
13:43 khall let me fix the strings, then we can fix that
13:43 cait :)
13:43 * cait makes a mental note - more chocolate for kyle
13:44 khall lol ; )
13:45 cait khall: the marc modification template translation didn#t turn out totally bad in pootle - but I still have to take a look how it turned out in the interface
13:45 khall that's good news!
13:45 oleonard Hooray for not totally bad!
13:45 cait It's still quite a tricky one - building sentences with variables is always
13:47 cait hi oleonard :)
13:49 seneca joined #koha
13:50 seneca Good morning if you're where I am and good everything else if you're not!
13:51 seneca Came in today and found my Koha (on Debian) installation unresponsive with nigh 100% CPU usage
13:52 seneca "top" tells me the CPU hogs are a couple of opac-main instances, a rebuild-zebra, and something I've not seen called 500.pl
13:52 seneca Anyone ever see this?
13:52 seneca Haven't done an upgrade lately, so not sure what changed between yesterday and today
13:53 oleonard 500.pl is the script that serves up the 500 error message
13:53 oleonard bots hitting the site?
13:53 seneca hmmm
13:53 seneca oh - it just dropped to 5-10%
13:53 seneca which is normal
13:53 seneca re: 500.pl - that makes sense ;)
13:54 nengard joined #koha
13:55 seneca wow, as soon as I hit refresh opac-main jumped to 90%+ and it took about 10 seconds for the page to show up
13:55 seneca then the CPu went back to normal
13:56 seneca then I did a search, and opac-search jumped up that high and it took another 10+seconds to return the results...
13:56 cait is there something unusual on your opac-main?
13:56 cait pulling in data from another source or something like that?
13:56 seneca right now rebuild-zebra and process-message are topping the list
13:56 khall cait: http://bugs.koha-community.org[…]_bug.cgi?id=11283 is ready for testing
13:56 huginn Bug 11283: normal, P5 - low, ---, koha-bugs, Needs Signoff , Restriction type is not translatable
13:57 khall also cait, you are referring to importing borrowers from a csv file, yes?
13:58 cait yes
13:59 cait in 3.6 you coud just have a debarred column and set it to 1, in 3.10+ it had to be a date... not sure what now :)
13:59 seneca yes, but nothing new...I suppose the other end could have changed something
13:59 seneca ?
13:59 seneca check it out yourself: libs.mvschool.com
13:59 seneca When no one's hitting the server, it seems to drop back down to normal
14:00 khall cait: nothing will change, it'll still need to be a date
14:00 cait oki :)
14:01 seneca thus, I don't think it's bots
14:03 seneca cait: what's on our opac-main is some pinterest widgets and a blogger widget
14:17 ebegin joined #koha
14:20 cait seneca: hm could those explain the load?
14:20 seneca it doesn't seem like those could... they're static pulls
14:20 seneca not anything that would use CPU
14:26 mtompset joined #koha
14:27 mtompset Greetings, #koha.
14:48 ebegin I just mentionned on twitter (@ericbegin) another advantage of open source.
14:49 ebegin francharb was working at biblibre in France before and is now working for inLibro, here in Montreal. That is what I called « No Employer Lock In ».
14:49 oleonard ebegin++
14:49 cait :)
14:50 cait ebegin: it's great he is working with you now :)
14:50 francharb :)
14:51 mtompset Interesting turn of phrase.
14:52 mtompset francharb: Were you a Canadian working in France, or are you a French person working in Canada now?
14:53 francharb mtompset, french working in canada now ;)
14:53 mtompset Welcome to Canada. :)
14:53 francharb thank you!
14:53 francharb where are you from mtompset ?
14:54 mtompset I'm in Ontario. I'm a Canadian. :)
14:54 francharb I guessed you were canadian... hehe
14:54 maximep joined #koha
14:54 francharb where in ontario?
15:12 mmm45 joined #koha
15:12 mmm45 hello
15:13 mmm45 I am trying to upgrade our catalog to 3.14.0
15:13 mmm45 but when running the dependencies i get errors like this one error building lib/Crypt/Eksblowfish.o from 'lib/Crypt/Eksblowfish.c' at /usr/local/share/perl/5.10.​1/ExtUtils/CBuilder/Base.pm line 177.
15:16 mmm45 Warning: Prerequisite 'Class::Mix => 0.001' for 'ZEFRAM/Crypt-Eksblowfish-0.009.tar.gz' failed when processing 'ZEFRAM/Class-Mix-0.005.tar.gz' with 'make_test => NO one dependency not OK (Params::Classify); additionally test harness failed'. Continuing, but chances to succeed are limited.
15:20 jcamins mmm45: sounds like you're installing using CPAN, which you should not do. Install the libcrypt-eksblowfish-perl package.
15:20 mmm45 ooohhhh
15:20 Oak joined #koha
15:20 mmm45 apt-get, right?
15:22 mmm45 sorry
15:22 mmm45 i must be doing something wrong
15:22 mmm45 E: Invalid operation libcrypt-eksblowfish-perl
15:22 jcamins You need to install it.
15:22 jcamins man apt-get
15:22 jcamins I mean, you need to install the package.
15:24 oleonard nengard: Bug 11288 is about the fact that there is a "not checked out" error message along with the hold message?
15:24 huginn Bug http://bugs.koha-community.org[…]_bug.cgi?id=11288 normal, P5 - low, ---, oleonard, NEW , checkin showing multiple error messages
15:25 mmm45 i installed the package as recommended
15:25 mmm45 i get this error in the browser
15:25 mmm45 "use" not allowed in expression at /home/koha/kohaclone/C4/Auth.pm line 79, at end of line syntax error at /home/koha/kohaclone/C4/Auth.pm line 79, near "head1 SYNOPSIS    use CGI" BEGIN not safe after errors--compilation aborted at /home/koha/kohaclone/C4/Auth.pm line 80.
15:25 nengard yes oleonard - which is actually an accurate message - but people are complaining so I complained on their behalf
15:26 oleonard In my tests that message appears going back to at least 3.8.x
15:26 oleonard I tested by checking in an item which wasn't checked out but had a hold on it.
15:26 nengard I thought it was there for a while
15:27 nengard I think when people are upgraded they notice things they didn't notice before ...
15:27 nengard did it always look the same?
15:27 jcamins mmm45: sounds like you might have tried to merge local changes, and ran into problems.
15:27 mmm45 aahhh
15:28 oleonard nengard: Styling has changed some in each version since 3.8.x
15:28 nengard Well I don't know why people are noticing it now ....
15:29 jcamins You'll need to fix whatever errors may have occurred. At a guess, the merge removed an = sign before head1 on that line.
15:29 jcamins Good luck.
15:29 oleonard The new style has caused their eyes to notice something that they had trained themselves to ignore? :)
15:30 nengard Could be
15:30 nengard happens to me too
15:30 nengard although usually i spot things that make me pleasantly surprised :)
15:30 nengard like "How did I miss that before?"
15:30 oleonard By the way nengard, the screenshot suggests to me that they  need to clear their browser cache to get the correct styling
15:30 nengard oh! Okay I'll mention that
15:31 oleonard We saw the same thing right after our upgrade
15:33 oleonard when did the password encryption change in Koha?
15:34 mmm45 [Mon Nov 18 12:41:49 2013] updatedatabase.pl: DBD::mysql::db do failed: Duplicate entry 'CalculateFinesOnReturn' for key 'PRIMARY' at /home/koha/kohaclone/installer​/data/mysql/updatedatabase.pl line 6976.
15:35 cait you can ignore that
15:35 cait that says you already had the pref
15:35 cait it got backported into your version most likely
15:36 mmm45 awesome
15:38 nengard oleonard bug 9611
15:38 huginn Bug http://bugs.koha-community.org[…]w_bug.cgi?id=9611 enhancement, P5 - low, ---, srdjan, Pushed to Master , Changing the password hashing algorithm from MD5 to more secure Bcrypt
15:42 oleonard Not in 3.12, so that doesn't have anything to do with the SIP login problems we're seeing randomly
15:45 nengard left #koha
15:45 cait the sip login is ugly
15:45 cait the code isnot using the api
15:45 cait but does it's own thing
15:46 cait we didn't have problems so fr, but right now I think it won't work with ldap for example
15:48 mmm45 any suggestions about this error: Bareword "C4::Auth_with_cas::multipleAuth" not allowed while "strict subs" in use at /home/koha/kohaclone/C4/Auth.pm line 1065. BEGIN not safe after errors--compilation aborted at /home/koha/kohaclone/C4/Auth.pm line 1607.
15:49 mmm45 or this: Compilation failed in require at /home/koha/kohaclone/mainpage.pl line 25. BEGIN failed--compilation aborted at /home/koha/kohaclone/mainpage.pl line 25.
15:54 mtompset mainpage.pl? That's because of your C4/Auth.pm problem.
15:55 cait mmm45: there might be other packages missing - they ar elisted in the release notes
15:55 mmm45 i'm not sure i understand what the problem is in C4/Auth
15:57 cait i'd make sure first you have all required dependencies installed
15:57 cait and then go from there
15:57 cait are you using CAS?
15:57 cait is one of the sysprefs activated?
15:58 mmm45 I am not using CAS
15:58 mtompset I suspect the Koha::AuthUtils fails, because you don't have the blowfish dependency.
15:58 mmm45 we are using Auth_with_ldap
15:58 mtompset Do you have koha_perl_deps.pl somewhere? Run that.
15:59 mmm45 i'll try it right now
15:59 mtompset -- /path/to/koha_perl_deps.pl -m -u
15:59 mtompset Actually -m -u -r, since there is no need to look for non-required dependencies.
16:00 mmm45 this is the required dependency: DBIx::Class::Schema::Loader
16:00 mtompset sudo apt-get install libdbix-class-schema-loader-perl
16:01 mtompset I think I ran into that lack of dependency myself last night.
16:01 mtompset I thought it was because I was rolling my own distribution.
16:02 * mtompset puts on his chauffeur hat.
16:02 mmm45 :-)
16:06 cait bye all have a nice weekend
16:06 cait left #koha
16:13 alex_a left #koha
16:28 reiveune bye
16:28 reiveune left #koha
16:53 ashimema joined #koha
16:56 oleonard Hi ashimema
16:59 cait joined #koha
17:18 jenkins_koha Starting build #133 for job Koha_3.12.x (previous build: STILL FAILING -- last SUCCESS #130 21 hr ago)
17:20 gaetan_B bye !
17:23 ashimema Hi Oleonard.
17:24 ashimema Sorry. slow reply.. been hoovering.. demstic bliss aye..
17:24 ashimema *domestic.. even
17:24 nengard joined #koha
17:24 oleonard I wondered what all the racket was
17:24 ashimema haha..
17:25 ashimema btw.. did you ever write up any notes on best practice with OPACUserCSS and OPACUserJS sysprefs with the bootstrap theme?
17:26 ashimema I still wonder whether some boilerplate aught to be put in those prefs at install time now bootstrap is default (maybe with the note to say it's bootstrap specific)
17:27 oleonard I got started on it: http://wiki.koha-community.org[…]ki/Bootstrap_OPAC
17:27 oleonard I'm working on a blog post too, but have lots of distractions at the moment
17:28 bag :)
17:28 bag distractions--
17:28 ashimema awesome.. that's a great start oleonard.. thanks for that..
17:28 oleonard Yes, down with anything distracting me from Koha!  ;)
17:28 ashimema I'll direct our staff to it.. they were quizzing me earlier about it.
17:29 bag sign me up for that too :D
17:29 ashimema likewise on the distractions front.. koha is the day job.. yet the day job still gets in the way ;)
17:31 jcamins oleonard: layouts for 0-390 and 342-479?
17:32 * oleonard shrugs
17:33 * jcamins is checking if one of those is a typo, and will fix it if it is.
17:34 jcamins It is not a typo.
17:34 jcamins Interesting.
17:34 wahanui well, interesting is sometimes good and sometimes bad
17:35 * cait waves
17:35 jcamins I guess both are in effect from 342-390 px wide.
17:44 jenkins_koha Project Koha_3.12.x build #133: STILL FAILING in 25 min: http://jenkins.koha-community.[…]/Koha_3.12.x/133/
17:50 jenkins_koha Starting build #134 for job Koha_3.12.x (previous build: STILL FAILING -- last SUCCESS #130 22 hr ago)
17:52 meliss joined #koha
17:57 tcohen ok, i don't belive you jenkins_koha
17:57 tcohen I released anyway
17:57 tcohen :-P
17:57 laurence left #koha
18:00 tcohen bye #koha
18:04 cait tcohen++
18:16 jenkins_koha Project Koha_3.12.x build #134: STILL FAILING in 26 min: http://jenkins.koha-community.[…]/Koha_3.12.x/134/
18:16 jenkins_koha * Tomas Cohen Arazi: Update release notes for 3.12.7 release
18:16 jenkins_koha * Bernardo Gonzalez Kriegel: Translation updates for 3.12.07 release
18:16 jenkins_koha * Tomas Cohen Arazi: Increment version for 3.12.7 release
18:54 francharb cait, wizzyrea , by the way! I found a solution for my items problem
18:54 francharb it was the database
18:54 cait oh!
18:54 francharb I dropped it
18:54 cait what was with it?
18:55 cait oh
18:55 cait and then it worked?
18:55 francharb and rerun the installer
18:55 francharb and it works
18:55 wahanui However, now everything else is broken.
18:55 oleonard Nice one wahanui
18:55 francharb :)
19:15 busla joined #koha
19:59 gmcharlt tcohen++
20:00 rambutan joined #koha
20:05 nengard joined #koha
20:07 cait good night!
20:07 wahanui It'll all be over soon...
20:09 nengard left #koha
20:26 pianohacker joined #koha
20:27 pianohacker hallo
20:30 bag hola pianohacker
20:37 tcohen joined #koha
20:43 * chris_n just discovered that sourcefire was purchased by cisco
20:43 chris_n I wonder how that will unfold for snort, clamav, and friends
20:53 tcohen #koha: what should we do about the utf8 bug?
20:53 jcamins tcohen: insist that everyone use English from now on?
20:53 tcohen heh
20:54 tcohen you should wave the sarcasm flag just in case
20:54 tcohen the thing is, i cannot reproduce any of the screenshots
20:55 NateC joined #koha
20:55 jcamins tcohen: maybe I'm serious.
20:55 tcohen sarcasm flag
20:55 jcamins lol
20:56 tcohen reproduced!
20:56 tcohen yeah, its damn broken
20:57 tcohen *sigh http://snag.gy/ypo4s.jpg
20:58 tcohen i'll close the bug as WONTFIX with a message deprecating multi-language support
20:58 jcamins Wow.
20:58 jcamins That's impressive.
20:58 tcohen that's evidence
20:58 jcamins That's really impressive.
20:58 pianohacker
20:58 rangi double encoding bites again
20:59 tcohen first, it doesn't break with ASCII+diacritics
20:59 jcamins Who knew that Đ was such a common letter?
20:59 tcohen so, we are letting Perl guess the encoding at some point
20:59 rangi and none if the patches fix it
20:59 rangi well they do, until you switch back to english
21:00 tcohen if someone takes a look at 11096, when i'm back from my honeymoon next week i'll take on this bug
21:00 rangi will do
21:00 pianohacker honeymoon? Congrats tcohen
21:01 rangi ah yep i started on that and found the eval thing, now its fixed i should be able to test and sign off
21:02 rangi tcohen: my guess is we are munching it on save
21:03 rangi and then trying to do the same thing again on display
21:03 tcohen that's correct, at some point
21:04 rangi yeah i think id start looking at where we save the category name
21:05 rangi but might be wrong
21:05 tcohen in english it shows ok.... so....
21:05 tcohen maybe is something about guessing the encoding of the translated templates
21:05 rangi yeah in english its ok, but the patches break it
21:05 rangi so yeah i think you are right
21:06 rangi what happens when you tell the browser its a different encoding?
21:07 tcohen iso is worse :-D
21:07 tcohen to reproduce just copy some russian strings and use it for description of the patron type
21:07 jcamins tcohen: did you try KOI8R?
21:07 rangi but you have to be running in non english templates
21:08 rangi thats why i couldnt reproduce
21:08 tcohen generate the ru-RU templates
21:08 rangi will give it a try
21:08 tcohen jcamins: yes, much uglier results
21:08 jcamins tcohen: huh.
21:08 tcohen gotta run
21:08 tcohen girlfriend freaking out...
21:08 tcohen heh
21:08 tcohen byeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeee
21:09 rangi hehe cya :)
21:09 tcohen gotta get her to the SPA
21:09 tcohen cya
21:10 busla joined #koha
21:15 fredy joined #koha
21:18 rangi yep i can totally reproduce but only in non english templates
21:19 rangi however it is only that patron categories
21:20 rangi if i go anywhere else it is fine, including in the patrons name etc
21:21 rangi so i think on the whole that its doing the right thing, just in one place we are messing up and double encoding the whole template, because the category is messing it up
21:22 jcamins rangi: I think patron categories is using a different template plugin, isn't it?
21:22 rangi could well be
21:22 rangi cos i note
21:22 rangi that on the modify page of a patron its fine
21:22 rangi and in the admin section fine also
21:23 rangi the only broken place i can find so far is that one page
21:29 rangi hmm
21:29 rangi >[% categorie.description | html_entity %]
21:31 pablito joined #koha
21:31 pablito hi
21:32 pablito can someone help me with a Koha installation error in the latest Debian
21:32 pablito I'm installing Koha 3.12 by sudo apt-get install koha-common
21:33 pablito and I got the following error:
21:33 rangi jcamins: and its not that, commenting out that include (patrons-toolbar.inc) and the page is still broken its the search one
21:33 rangi jcamins: im not expecting you to answer just talking out loud :)
21:34 rangi and its definitely patron-search.inc that is the culprit
21:36 rangi pablito: didnt see your error
21:36 pablito koha-common : Depends: libalgorithm-checkdigits-perl but it is not installable
21:36 pablito Depends: libauthen-cas-client-perl but it is not installable
21:36 pablito Depends: libbiblio-endnotestyle-perl but it is not installable
21:36 pablito Depends: libbusiness-isbn-perl but it is not installable
21:37 pablito Depends: libcache-memcached-fast-perl but it is not installable
21:37 pablito Depends: libcgi-session-driver-memcached-perl but it is not going to be installed
21:37 pablito Depends: libcgi-session-serialize-yaml-perl but it is not installable
21:37 pablito Depends: libdata-ical-perl but it is not installable
21:37 pablito Depends: libdatetime-event-ical-perl but it is not installable
21:37 pablito Depends: libdatetime-format-dateparse-perl but it is not installable
21:37 pablito there are more similar lines of erros after this
21:38 rangi and you have the right apt repo set up eh?
21:38 pablito I have this: deb http://debian.koha-community.org/koha squeeze main
21:38 pablito in my koha.list file
21:39 rangi because those are all there
21:39 rangi what does
21:39 rangi apt-cache policy libcgi-session-driver-memcached-perl
21:39 rangi tell you
21:39 rangi or
21:40 rangi any of the others
21:43 pablito libcgi-session-driver-memcached-perl:
21:43 pablito Installed: (none)
21:43 pablito Candidate: 0.04-2
21:43 pablito Version table:
21:43 pablito 0.04-2 0
21:43 pablito 500 http://debian.koha-community.org/koha/ oldstable/main amd64 Packages
21:43 rangi what happens if you just try to install that?
21:43 pablito well, I tried the repo for 3.12 it didn't work, so I revert to the oldstable 3.10 and same error
21:44 jcamins pablito: oldstable is now 3.12.
21:44 jcamins squeeze is 3.14.
21:44 pablito ah ok
21:44 rangi no if you try to install the missing dependencies?
21:45 jcamins I think. eythian was packaging 3.14 last night, so I presume he changed squeeze to 3.14 and oldstable to 3.12.
21:45 pablito i tried running: sudo apt-get -f install and nothing happpened
21:45 jcamins pablito: but what about `sudo apt-get install libcgi-session-driver-memcached-perl`?
21:46 pablito Reading package lists... Done
21:46 pablito Building dependency tree
21:46 pablito Reading state information... Done
21:46 pablito Some packages could not be installed. This may mean that you have
21:46 pablito requested an impossible situation or if you are using the unstable
21:46 pablito distribution that some required packages have not yet been created
21:46 pablito or been moved out of Incoming.
21:46 pablito The following information may help to resolve the situation:
21:46 pablito The following packages have unmet dependencies:
21:46 pablito libcgi-session-driver-memcached-perl : Depends: libcache-memcached-perl but it is not installable or
21:46 pablito libcache-memcached-fast-perl but it is not installable
21:46 wahanui i already had it that way, pablito.
21:46 pablito E: Unable to correct problems, you have held broken packages.
21:47 pablito hmm>
21:47 pablito ?
21:47 rangi ah yeah theres your problem those should be in your full debian repo
21:47 rangi libcache-memcached-perl
21:47 rangi is in debian proper
21:47 pablito so what should I do?
21:48 rangi what does apt-cache policy libcache-memcached-perl
21:48 rangi say
21:48 pablito it says:
21:48 rangi (this isnt really a koha problem now, those packages are in koha, not in debian so you should check you apt sources )
21:48 pablito libcache-memcached-perl:
21:48 pablito Installed: (none)
21:48 pablito Candidate: (none)
21:48 pablito Version table:
21:49 rangi yeah theres the problem
21:49 rangi that is definitely in wheezy
21:49 pablito so you want me to show the content of sources.list?
21:49 rangi http://packages.debian.org/whe[…]he-memcached-perl
21:49 rangi not really no
21:50 rangi but you need to figure out why you dont have a correct setup for debian
21:50 pablito yeh, that's what I'm afraid of
21:50 pablito someone else setup debian for me
21:50 rangi ahh
21:50 jcamins Also, as an aside, use libcache-memcached-fast-perl not libcache-memcached-perl.
21:51 busla joined #koha
21:51 rangi maybe its still set up to use a dvd or cd instead of the debian apt repos
21:51 jcamins Cache::Memcached is not Unicode safe.
21:51 pablito ah that's it
21:51 pablito the sources.list indicates that
21:51 rangi you'll need to fix that
21:51 pablito so I should comment it out righgt?
21:52 rangi if it has settings of a proper one then yep
21:52 rangi if not commenting it out wont fix it until you have that
21:53 pablito can you give me an example of a good repot setting?
21:55 pianohacker What's Bernardo's username? bgkriegel?
21:56 rangi yep pianohacker
21:57 rangi pablito: can you do this
21:57 pianohacker thanks rangi
21:57 rangi sudo apt-get install netselect
21:57 rangi i hope that is on the dvd
21:57 rangi doesnt matter if you cant, that will just help you find a fast/close server
21:58 pablito ah ok
21:58 rangi netselect-apt is even better
21:58 pablito ok
21:58 pablito i already comment out the DVD repo
21:58 pianohacker rangi: Posted an update to bug 10486 that fixes another pazpar2 configuration issue
21:58 huginn Bug http://bugs.koha-community.org[…]_bug.cgi?id=10486 new feature, P5 - low, ---, jweaver, Needs Signoff , Allow external Z39.50 targets to be searched from the OPAC
21:59 rangi sudo netselect-apt wheezy
21:59 rangi or just pick one from
21:59 rangi http://www.debian.org/mirror/list
21:59 pablito ok
22:00 pianohacker (and thanks for rebasing the patch)
22:01 rangi sweet
22:01 rangi fixed the issue
22:05 francharb bye all
22:05 francharb have a good week end!
22:06 jenkins_koha Starting build #358 for job Koha_3.8.x (previous build: SUCCESS)
22:12 pablito rangi: I put in the nearest repo in sources.list and updated but still get the same errors
22:12 pablito The following packages have unmet dependencies:
22:12 pablito koha-common : Depends: libauthen-cas-client-perl but it is not going to be installed
22:12 pablito Depends: libcache-fastmmap-perl but it is not going to be installed
22:12 pablito Depends: libcache-memcached-fast-perl but it is not going to be installed
22:12 pablito Depends: libcache-perl but it is not going to be installed
22:13 pablito Depends: libcgi-session-driver-memcached-perl but it is not going to be installed
22:13 wahanui i already had it that way, pablito.
22:13 pablito Depends: libcgi-session-serialize-yaml-perl but it is not going to be installed
22:13 pablito Depends: libclass-accessor-perl but it is not going to be installed
22:13 pablito Depends: libcrypt-eksblowfish-perl but it is not going to be installed
22:13 pablito Depends: libdata-ical-perl but it is not going to be installed
22:13 pablito Depends: libdata-paginator-perl but it is not going to be installed
22:13 pablito Depends: libdate-calc-perl but it is not going to be installed
22:13 pablito Depends: libdate-manip-perl but it is not going to be installed
22:13 pablito Depends: libdatetime-event-ical-perl but it is not going to be installed
22:13 pablito Depends: libdatetime-format-dateparse-perl but it is not going to be installed
22:13 pablito Depends: libdatetime-format-ical-perl but it is not going to be installed
22:13 pablito Depends: libdatetime-format-mysql-perl but it is not going to be installed
22:13 pablito Depends: libdatetime-perl but it is not going to be installed
22:13 rangi well
22:13 pablito Depends: libdatetime-set-perl but it is not going to be installed
22:13 pablito Depends: libdatetime-timezone-perl but it is not going to be installed
22:13 pablito Depends: libdbd-mock-perl but it is not going to be installed
22:13 pablito Depends: libdbd-mysql-perl but it is not going to be installed
22:13 pablito Depends: libdbd-sqlite2-perl but it is not going to be installed
22:13 pablito Depends: libdbi-perl but it is not going to be installed
22:13 pablito Depends: libdbix-class-schema-loader-perl but it is not going to be installed
22:13 rangi you obviously didnt get a valid repo in there
22:13 pablito Depends: libgd-barcode-perl but it is not going to be installed
22:13 pablito Depends: libgd-gd2-noxpm-perl but it is not going to be installed or
22:13 pablito libgd-gd2-perl but it is not going to be installed
22:13 pablito Depends: libgraphics-magick-perl but it is not going to be installed
22:13 pablito Depends: libgravatar-url-perl but it is not going to be installed
22:13 pablito Depends: libhttp-oai-perl but it is not going to be installed
22:13 pablito Depends: liblingua-stem-snowball-perl but it is not going to be installed
22:13 pablito Depends: liblist-moreutils-perl but it is not going to be installed
22:13 rangi and yeah that was a bit of a big paste
22:13 pablito Depends: libmarc-charset-perl but it is not going to be installed
22:13 pablito Depends: libmarc-crosswalk-dublincore-perl but it is not going to be installed
22:13 pablito Depends: libmemoize-memcached-perl but it is not going to be installed
22:13 pablito Depends: libmoose-perl but it is not going to be installed
22:13 pablito Depends: libmoosex-storage-perl but it is not going to be installed
22:13 pablito Depends: libmoosex-types-perl but it is not going to be installed
22:13 jcamins For future reference, we have a pastebin at paste.koha-community.org
22:13 pablito Depends: libnet-z3950-zoom-perl but it is not going to be installed
22:13 pablito Depends: libpdf-reuse-barcode-perl but it is not going to be installed
22:13 rangi you will need to fix your debian
22:13 pablito Depends: libpoe-perl but it is not going to be installed
22:13 pablito Depends: libreadonly-xs-perl but it is not going to be installed
22:13 pablito Depends: libsms-send-perl but it is not going to be installed
22:14 pablito Depends: libstring-rewriteprefix-perl but it is not going to be installed
22:14 pablito Depends: libtemplate-perl but it is not going to be installed
22:14 pablito Depends: libtest-strict-perl but it is not going to be installed
22:14 pablito Depends: libtest-www-mechanize-perl but it is not going to be installed
22:14 pablito Depends: libtest-yaml-valid-perl but it is not going to be installed
22:14 pablito Depends: libtext-csv-xs-perl but it is not going to be installed
22:14 pablito Depends: libtext-unaccent-perl but it is not going to be installed
22:14 pablito Depends: libxml-libxml-perl but it is not going to be installed
22:14 pablito Depends: libxml-libxslt-perl but it is not going to be installed
22:14 pablito Depends: libxml-rss-perl but it is not going to be installed
22:14 pablito Depends: libyaml-perl but it is not going to be installed
22:14 pablito Depends: libyaml-syck-perl but it is not going to be installed
22:14 pablito Depends: apache2
22:14 pablito Depends: apache2-mpm-itk but it is not going to be installed
22:14 pablito Depends: mysql-client
22:14 pablito Depends: perl-doc but it is not going to be installed
22:14 pablito E: Unable to correct problems, you have held broken packages.
22:14 pablito sorry
22:14 pablito hehe
22:14 pablito ok, thanks
22:16 rangi try
22:16 rangi sudo apt-get clean && sudo apt-get update
22:17 rangi if that doesnt work, you might want to try a debian channel or something
22:23 rambutan I'm glad rangi isn't given to understatement
22:24 pablito it still doesn't work, but thank you for your help
22:24 pablito have a good night/day everyone :-)
22:45 jenkins_koha Project Koha_3.8.x build #358: SUCCESS in 39 min: http://jenkins.koha-community.[…]b/Koha_3.8.x/358/
22:45 jenkins_koha * Galen Charlton: bug 10728: fix additional log noise generated by subscription-renew.pl
22:45 jenkins_koha * Jonathan Field: Bug 10704: make OPAC highlighting work across previous/next travel
22:45 huginn Bug http://bugs.koha-community.org[…]_bug.cgi?id=10728 trivial, P5 - low, ---, colin.campbell, Pushed to Stable , subscription-renew generates unnecessary warnings in logs
22:45 huginn Bug http://bugs.koha-community.org[…]_bug.cgi?id=10704 trivial, P5 - low, ---, gmcharlt, Pushed to Stable , Search term highlighting doesn't work beyond the first results page
22:46 jenkins_koha Starting build #359 for job Koha_3.8.x (previous build: SUCCESS)
22:54 fredy joined #koha
23:10 pianohacker rangi: I apologize, I really do not know why I continue to struggle so much with licenses
23:29 jenkins_koha Project Koha_3.8.x build #359: SUCCESS in 43 min: http://jenkins.koha-community.[…]b/Koha_3.8.x/359/
23:29 jenkins_koha * Owen Leonard: Bug 10765 - [SIGNED-OFF] Update POD of C4::Koha::GetSupportList() to use TT syntax
23:29 jenkins_koha * Owen Leonard: Bug 10764 - Update POD of C4::Items::GetItemStatus() to use TT syntax
23:29 jenkins_koha * Owen Leonard: Bug 10763 - [SIGNED-OFF] Update POD of C4::Creators::Lib::html_table() to use TT syntax
23:29 jenkins_koha * Owen Leonard: Bug 8670 - Update POD of C4::Branch::GetBranches() to use TT syntax
23:29 jenkins_koha * Tomas Cohen Arazi: Bug 10645: adding missing zebra languages to koha-create manpage
23:29 huginn Bug http://bugs.koha-community.org[…]_bug.cgi?id=10765 trivial, P5 - low, ---, oleonard, Pushed to Stable , Update POD of C4::Koha::GetSupportList() to use TT syntax
23:29 huginn Bug http://bugs.koha-community.org[…]_bug.cgi?id=10764 trivial, P5 - low, ---, oleonard, Pushed to Stable , Update POD of C4::Items::GetItemStatus() to use TT syntax
23:29 huginn Bug http://bugs.koha-community.org[…]_bug.cgi?id=10763 trivial, P5 - low, ---, oleonard, Pushed to Stable , Update POD of C4::Creators::Lib::html_table() to use TT syntax
23:29 huginn Bug http://bugs.koha-community.org[…]w_bug.cgi?id=8670 trivial, P5 - low, ---, oleonard, Pushed to Stable , Update POD of C4::Branch::GetBranches() to use TT syntax
23:29 huginn Bug http://bugs.koha-community.org[…]_bug.cgi?id=10645 trivial, P5 - low, ---, tomascohen, Pushed to Stable , Missing zebra languages in koha-create manpage

| Channels | #koha index | Today | | Search | Google Search | Plain-Text | plain, newest first | summary